login   |    register
Tools & Supplies
Discussions on the latest and greatest tools, glues, and gadgets.
Hosted by Matt Leese
MMP Paints Questions
plastickjunkie
_VISITCOMMUNITY
Florida, United States
Joined: December 31, 2009
KitMaker: 397 posts
RailRoad Modeling: 0 posts
Posted: Thursday, July 23, 2020 - 01:30 PM UTC
I bought several bottles at a model show I attended a couple of years back and finally got to use it on a 1/72 Trumpy F-105G. I simply followed the directions and used their thinner and poly additive and was really impressed at how well it went thru my gravity fed Neo. No tip dry, skipping or spitting but smooth tight feathered demarcation lines were consistent.

The trick to this paint is not to thin it as one would with other paints. To be honest, I was skeptical at first when i saw how thick the paint was in my ab cup even after the suggested thinner ratio was mixed in. It's very important to follow the product directions.
Scarred
_VISITCOMMUNITY
Washington, United States
Joined: March 11, 2016
KitMaker: 1,653 posts
RailRoad Modeling: 2 posts
Posted: Thursday, April 09, 2020 - 06:53 AM UTC
The trend in paints today is proprietary formulations that only work with their products. Always read the instructions and I'm sure you'll see they recommend their primers, thinners, finishes and everything else.

I've found out over the decades that if a paint manufacturer, let's say Testors, makes a thinner and primer then use those. Same with Vallejo, Ammo of Mig, Tamiya, AK and all the rest. It will save you hours of heartache and frustration.
LowFiveJoe_2
_VISITCOMMUNITY
Virginia, United States
Joined: December 28, 2017
KitMaker: 47 posts
RailRoad Modeling: 0 posts
Posted: Thursday, April 09, 2020 - 06:07 AM UTC
Thanks Mike,

I've since acquired MMP's primer, and the latest test seems to be working. I'm guessing their paint wasn't working well with Tamiya. Nothing else has changed. It is definitely a learning curve with this brand. It has potential though.
VintageRPM
_VISITCOMMUNITY
Texas, United States
Joined: November 28, 2010
KitMaker: 290 posts
RailRoad Modeling: 0 posts
Posted: Thursday, April 09, 2020 - 12:51 AM UTC
All (or at least most) aqueous acrylic paints require primer underneath. You can use any brand you like. I usually use Velejo airbrushed or Tamiya out of the rattle can.
LowFiveJoe_2
_VISITCOMMUNITY
Virginia, United States
Joined: December 28, 2017
KitMaker: 47 posts
RailRoad Modeling: 0 posts
Posted: Tuesday, April 07, 2020 - 04:47 AM UTC
Hi All,

Looking for some tips on MMP acrylic paint. I've been on the MMP site and watched the YouTube videos, but my first three tries ended in complete failure. I made sure to shoot it "wet" and let it dry. Tried it with MMP thinner, without, with the poly, and without. As soon as I touch the dried paint it brushes right off. I can completely remove the coat with warm water and gentle scrubbing with a soft brush.

I've ordered MMP primer, and am going to try again on my mule. Maybe the MMP 'system' requires MMP primer under? Previous attempt was Tamiya fine surface primer. Maybe not enough of a surface for the MMP paint to adhere to?

Any help is appreciated, thanks.